Upgrade ULTRAVNC repeater

CLOSED
Bids
2
Avg Bid (EUR)
150
Project Budget (EUR)
€30 - €250

Project Description:
Upgrade ULTRAVNC modified repeater to be compatilbe with ULTRAVNC servers up to version 1.1.
Negotiated RFB version can be 3.3 as long as it works.
Existing repeater works with ULTRAVNC server versions up to 1.0.8.2. support is broken with version 1.0.9.2 (probably changes with RFB version)

Sources and description... http://code.google.com/p/vncrepeater/ (this repater has 100% CPU usage bug), use this version without bug ... https://github.com/XSoftBG/repeater

Detailed problem description (I presume, that you are familiar with ULTRAVNC repeater concept):


On our linux server we run repeater from link https://github.com/XSoftBG/repeater
Then we make a reverse vnc connection (Ultravnc Server 1.0.8.2) from client computer to repeater, than technician makes viewer vnc connection (standard vnc viewers), and select VNC server session ID with a password request as described on link http://code.google.com/p/vncrepeater/, vnc connection works.

If we replace VNC server on client computer with newer version (ULTRAVNC server 1.0.9.2 and newer,also ultravnc.ini must contain authrequired=0), conection to repeater is successful, but viewer connection doesnt work. (different errors on different viewers). I presume, that problem is in different handshake procedure on newer ULTRAVNC servers.

What we need is changes on repeater code, so repeater would support connections with newer ultravnc servers....

You will need testing enviroment with repeater...

Regards, Gregor

Skills required:
C++ Programming
Hire gregorzorz
Project posted by:
gregorzorz Slovenia
Verified
Public Clarification Board
Bids are hidden by the project creator. Log in as the employer to view bids or to bid on this project.
You will not be able to bid on this project if you are not qualified in one of the job categories. To see your qualifications click here.


Hire BOJ64V1ea
€ 250
in 1 days
€ 50
in 5 days