Configuring debian 3.1 web server

IN PROGRESS
Bids
9
Avg Bid (USD)
$57
Project Budget (USD)
$30 - $100

Project Description:
System: Kernel 2.6.8-2-k7
CPU model AMD Athlon(tm) 64 Processor 3700+
CPU MHz 2199.98
RAM: 1GB

Linux Debian 3.1 Sarge with common apps like Apache, MySQL, PostgreSQL, PHP, Perl, Python, gcc, Webmin, OpenSSL, Yast 2, Postfix, etc.. pre-installed

Our project is probably very easy for someone skilled in linux and web server configuration. The server already has all application software installed and just needs to be configured properly.

Here is the situation:

We need to be able to add in domains (also on subnet IP's) with ease so we wanted something else than webmin.

First we set up and configured bind. Bind seems to be running ok and we can manually add domains and have them resolved accross the internet.

Then for the domain adding interface we wanted to setup/manage virtual directories and such, we choose VHCS. Using a script we found on http://wael.nasreddine.com/Articles/Articles/Install_VHCS_on_Ubuntu_%10_Debian.html we installed VHCS2 without too much hassle

Then we added the sub domain to the /etc/network/interfaces and it now looks something like:

###Loopback (lo):
auto lo
iface lo inet loopback

###Interface (eth0):
auto eth0
iface eth0 inet static
address 88.198.xxx.xxx
broadcast 88.198.xxx.xxx
netmask 255.255. xxx.xxx
gateway 88.198.xxx.xxx

## Additional subnet
auto eth0:1
iface eth0:1 inet static
address 88.198.xxx.xxx
broadcast 88.198.xxx.xxx
netmask 255.255. xxx.xxx
gateway 88.198.xxx.xxx

All seemed ok so far, but then Apache started giving us trouble:
debian3132lamp:/etc# /etc/init.d/apache2 restart
Forcing reload of web server: Apache2(98)Address already in use: make_sock: could not bind to address [::]:80
no listening sockets available, shutting down
Unable to open logs

Ok so here is the first problem... Something is hogging up port 80 or it wont bind to the network address correctly for some reason.

Then we try to restart the network and:
debian3132lamp:/etc# /etc/init.d/networking restart
Setting up IP spoofing protection: rp_filter.
Reconfiguring network interfaces...SIOCDELRT: No such process
ifup: interface lo already configured
done.

Not sure if that error means we set up our subnet wrong or what it means exactly.. However, we need to do a network restart each time the server reboots for dns to work.. dunno why, but something is wrong here&

Anyway, our webserver provider does not offer any software support and we need some help to get the server going properly.

You can eigther:
a) configure what we set up already to work
b) uninstall what we did so far (bind, vhcs) and install something else.

What we want is:
1. The subnet with 64 IP's to be set up correctly in addition to our main IP. Check that bind and other critical webserver enviroment programs are set up correctly.
2. To be able to add in domains (set on subnet IPs) with ease. By using a control panel, script.. or whatever. As long as its easy/quick. Something that creates virtual directories etc and makes life easier.

Hope this makes the situation clear and you understand what we want to have done. PM if you need more details.

Skills required:
Linux, Script Install, System Admin, Web Security
Hire MortenB
Project posted by:
MortenB Thailand
Verified
Public Clarification Board
Bids are hidden by the project creator. Log in as the employer to view bids or to bid on this project.
You will not be able to bid on this project if you are not qualified in one of the job categories. To see your qualifications click here.