i want someone to deploy nextjs app on aws amplify.

Completed Posted 2 months ago Paid on delivery
Completed Paid on delivery

I am looking for someone who can help me solve this error while deploy my pre-existing NextJS application on AWS Amplify.

- Strong knowledge of NextJS and AWS Amplify

# Starting phase: preBuild

# Executing command: npm ci

2023-12-01T22:53:55.455Z [WARNING]: npm

2023-12-01T22:53:55.456Z [WARNING]: WARN EBADENGINE Unsupported engine {

npm WARN EBADENGINE package: 'next@14.0.3',

npm WARN EBADENGINE required: { node: '>=18.17.0' },

npm WARN

2023-12-01T22:53:55.457Z [WARNING]: EBADENGINE current: { node: 'v16.19.0', npm: '8.19.3' }

npm WARN EBADENGINE }

2023-12-01T22:54:10.862Z [INFO]: added 559 packages, and audited 560 packages in 18s

2023-12-01T22:54:10.863Z [INFO]: 124 packages are looking for funding

run `npm fund` for details

2023-12-01T22:54:10.866Z [INFO]: 3 moderate severity vulnerabilities

To address all issues (including breaking changes), run:

npm audit fix --force

Run `npm audit` for details.

2023-12-01T22:54:10.880Z [INFO]: # Completed phase: preBuild

2023-12-01T22:54:10.881Z [INFO]: # Starting phase: build

# Executing command: npm run build

2023-12-01T22:54:11.189Z [INFO]: > bajilive@0.1.0 build

> next build

2023-12-01T22:54:11.456Z [WARNING]: unhandledRejection ReferenceError: Headers is not defined

at Object.<anonymous> (/codebuild/output/src2445085648/src/bajivai_frontend/node_modules/next/dist/server/web/spec-extension/adapters/[login to view URL]:30)

at Module._compile (node:internal/modules/cjs/loader:1165:14)

at Object.Module._extensions..js (node:internal/modules/cjs/loader:1219:10)

at [login to view URL] (node:internal/modules/cjs/loader:1043:32)

at Function.Module._load (node:internal/modules/cjs/loader:878:12)

at [login to view URL] (node:internal/modules/cjs/loader:1067:19)

at [login to view URL] (/codebuild/output/src2445085648/src/bajivai_frontend/node_modules/next/dist/server/[login to view URL]:28)

at require (node:internal/modules/cjs/helpers:103:18)

at Object.<anonymous> (/codebuild/output/src2445085648/src/bajivai_frontend/node_modules/next/dist/server/api-utils/[login to view URL]:18)

at Module._compile (node:internal/modules/cjs/loader:1165:14)

2023-12-01T22:54:11.464Z [ERROR]: !!! Build failed

2023-12-01T22:54:11.464Z [INFO]: Please read more about Amplify Hosting's support for SSR frameworks to find if your build failure is related to an unsupported feature: [login to view URL] You may also find this troubleshooting guide useful: [login to view URL]

2023-12-01T22:54:11.464Z [ERROR]: !!! Non-Zero Exit Code detected

2023-12-01T22:54:11.465Z [INFO]: # Starting environment caching...

2023-12-01T22:54:11.465Z [INFO]: # Environment caching completed

Terminating logging...

AWS Amplify Next.js

Project ID: #37499831

About the project

2 proposals Remote project Active 2 mos ago

Awarded to:

(2 Reviews)
2.3

2 freelancers are bidding on average ₹2050 for this job

jawed7siddiqui2

Hello ,I'm NextJS developer & hv 8 yr exp, I feel very much interested to work with you. I can assure you that I will do my best to do your job. Regards

₹2050 INR in 7 days
(0 Reviews)
0.0